alphaMELTS 1.9 is available at the download and information site.
alphaMELTS 2 standalone & for MATLAB/Python are available on request
(see the Version 2 tab on the download site for more details).
For news of all MELTS software see the MELTS Facebook page.

Main Menu

Comma Problem

Started by, July 25, 2022, 04:26:49 AM

Previous topic - Next topic


I installed rhyolite_MELTS for Mac OSX on my laptop that is setup for European countries.

When I start the program the GUI pops up and everything seems to work as I have access to all the different functions. However, I stared to have a problem when I entered my chemical compositions. Indeed, when I enter "AL2O3= 17.38",  the soft returned the value "17,000". I have the same problem when I load the MORB test file. I tried to enter "17,38", but the program does not accepts the comma decimal separator. I need to use the "dot" decimal separator and he returns the comma and drop all the decimal numbers. I have tried to change the decimal separator from "," to "." in operating system and keyboard, but this does not help.

Do you have any idea how to solve this issue?
Thanks for your help,

Antoine Bézos


You probably need to change the keyboard input from French to English:,766.0.html

Thanks to Jose!

Hello Paula,

Thank you for your answer!
Yes I have read Jose's post before. Lucky him, the trick didn't work from me!
I have tried to install MELTS on linux and it does the same thing...
Thanks anyway,

Best regards,


Hi Antoine,

Ah, sorry that didn't work. You could try easyMelts. It can do everything that the old GUI can. I don't know if it will get around the comma problem but it would be interesting to see: