Author Topic: X410 version of rhyolite-MELTS display is tiny on high-resolution screen  (Read 19 times)

Paula

  • Administrator
  • Hero Member
  • *****
  • Posts: 254
    • View Profile
    • My GPS Division profile
X410 is pretty new software. The ability to run (older) apps scaled like this is amongst the feature requests. So it's possible that this workaround will not be needed with future versions of X410. Check out Running X410 on HiDPI Screens and other Howto entries on the Choung Networks site for more current details.

If you followed the instructions for enabling the WSL and installing the Rhyolite-MELTS GUI (new for 2018) on a laptop with a high-resolution screen, such as the Surface, you may find that the rhyoliteMELTS display looks tiny. There is a workaround for this behavior that should work for most X server software here.

However, if your X server is X410, then this 'bug' is actually a 'feature' ;) The idea is that Linux software that can deal with scaling for a high resolution screen should be allowed to do so (see Running X410 on HiDPI Screens). There is no way to make the rhyolite-MELTS GUI run in a high-resolution mode - the interface is too old - but there is a way to run rhyolite-MELTS with a user-defined scaling (actually it runs xterm, which is then used to open rhyolite-MELTS). This alternative workaround does not require admin access but only works for ubuntu 18.04 LTS... or at least it is difficult enough in ubuntu 16.04 LTS, that it is easier to install ubuntu 18.04 and 16.04 side by side than to attempt it!

This workaround does not require admin access (other than the one-off access you needed to set up the WSL in the first place) and uses the same formatting conventions as the WSL setup post i.e. things should type at the command line are in bold in quote boxes; names you should substitute are in italics and comments are preceded by ellipsis (...). Note that by 'command line', we mean the Ubuntu bash shell that opens when you click the 'ubuntu' program and not the Windows Command Prompt (cmd.exe). If it all seems like too much trouble, then there is always the option to use Windows' Ease of Access tools as a workaround; scroll down to the bottom for this alternative.

Use run_scaled to adjust the rhyolite-MELTS windows size

This solution uses Alexander Kauer's run_scaled script. If you didn't set up the 'bin' folder and path at the time then consult the "If you did not install alphaMELTS" section of the enabling the WSL etc. post for details on how to do this first. Otherwise, open ubuntu 18.04 LTS, which may be just called 'ubuntu' on your system:
Quote
cd bin
... if this gives an error, make sure the 'bin' folder and path are set up
wget raw.githubusercontent.com/kaueraal/run_scaled/master/run_scaled
... this downloads the run_scaled script as plain text because going through a Windows-based browser causes problems with line-endings etc.
cat run_scaled

We also need to install some libraries that are not included in the default ubuntu installation:
Quote
sudo apt install xterm xvfb xpra python-numpy python-opencv
... enter your Linux password when prompted and choose 'y' to install the necessary packages (there will be quite a lot of them)

Now navigate to where you want to start rhyolite-MELTS. Make sure X410 is running (else you will get an error like "Can't open display :0"). When you use run_scaled you will likely get several warnings, but most of them can be ignored.
Quote
run_scaled
... if you don't give any other input you will get the usage information for run_scaled
... note that the '--sleep' option can be used if you are getting 'InitException' errors on start up
run_scaled xterm
... or
run_scaled --sleep=5 xterm

If you are lucky, this will open a second terminal program; the text will look a little fuzzy because of the scaling. Increase the sleep value if needed (it's not that your machine is very slow, it's just that the WSL wasn't really intended for running windowed apps).
Quote
Melts-rhyolite
... or './Melts-rhyolite-public' if you didn't set up the path before
... answer the normal questions to select rhyolite-MELTS 1.0.2, 1.1.0, 1.2.0, or pMELTS

The default scaling factor is 2, which works well on my set up, but you can experiment with other values, including non-integer values, in the original terminal. Close the rhyolite-MELTS and xterm windows before typing 'run_scaled --scale=scale_factor' (with or w/o a sleep value).

Using Magnifier (does not require any additional setup)

Open Settings (click either the Start button in the bottom LH corner or the Notification icon bottom RH corner; then click the cog icon). Type 'Magnifier settings' in the search box. Reduce the Zoom level increments to 25%. You can experiment with the Magnification zoom level but something in the range 150 - 200% is likely to work. You probably want to leave the 'Start Magnifier...' boxes unchecked and put the Magnifier mode in 'Full Screen'. Turn the Magnifier on, scroll down and right-click the Magnifier icon and choose 'Pin to taskbar'. Now if you turn off the Magnifier (by clicking the 'X' in the top RH corner of the Magnifier popup), you can easily turn it on again by selecting it from the taskbar; the cog on the Magnifier popup is a shortcut to the Settings page.

Paula
« Last Edit: September 21, 2018, 04:34:28 pm by Paula »