Author Topic: Troubleshooting alphaMELTS installation on WSL  (Read 172 times)

Paula

  • Administrator
  • Hero Member
  • *****
  • Posts: 411
    • View Profile
    • My GPS Division profile
Troubleshooting alphaMELTS installation on WSL
« on: April 23, 2020, 03:51:24 pm »
Originally the Ubuntu Windows Subsystem for Linux (WSL) did not have a .profile file in the user's home space by default, which made installing alphaMELTS very easy. More recent versions may have a .profile file, which is a hidden file used, amongst other things, to set the user's PATH variable within Linux. Even if you have a clean install of the WSL, the alphaMELTS install.command script may still give a warning about .profile existing "so not going to edit it!"

The script will tell you what you need to add to the .profile file, but as you shouldn't edit WSL files with Windows tools (like Notebook for example) this may be tricky. One option is to use the command line text editor 'nano'. First right-click the Ubuntu icon and select Properties. Make sure Quick Edit Mode is on. You might want to select "Enable Ctrl key shortcuts", and you probably want "Use legacy console" to be off.
  • Highlight the text that install.command said you should add to .profile; right-click once, or if you have checked "Enable Ctrl key shortcuts" you can use Ctrl+C
  • Type "cd" then "nano .profile" at the command line (the first just makes sure you are in your home directory)
  • Use arrow keys to navigate down to somewhere you can insert the block of text; then right-click to paste
  • Ctrl+O to save, then Crtl+X to exit nano
  • Finally type "exit" to close the WSL and restart
Alternatively, on a new WSL installation the following hack should work:
  • At the command line type "cd" then "mv .profile profile1"
  • Then install alphaMELTS in the usual way
  • Type "cd", then "mv .profile profile2", followed by "cat profile1 profile2 > .profile"
  • Finally type "exit" to close the WSL and restart
Any problems, let me know.

Paula
« Last Edit: April 23, 2020, 04:32:59 pm by Paula »