Author Topic: Library error when running Melts-rhyolite in Windows x64  (Read 105 times)

timothygenda

  • Newbie
  • *
  • Posts: 2
    • View Profile
Library error when running Melts-rhyolite in Windows x64
« on: August 07, 2020, 02:43:41 pm »
Hello,
I've been trying to follow download instructions for rhyolite MELTS in Windows that were posted here: (https://magmasource.caltech.edu/forum/index.php/topic,959.0.html).

However, when I attempt to run the program by typing 'Melts-rhyolite' in the Ubuntu command line, I receive the following error:

"Melts-rhyolite: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory"

I did update all my ubuntu libraries, and tried while running the X410 server and and also while running the Xming server. Any idea what I'm doing wrong here?

Any help is much appreciated!

Paula

  • Administrator
  • Hero Member
  • *****
  • Posts: 412
    • View Profile
    • My GPS Division profile
Re: Library error when running Melts-rhyolite in Windows x64
« Reply #1 on: August 07, 2020, 03:04:48 pm »
Hi,

This error was discussed on the Linux board, so easy to miss (https://magmasource.caltech.edu/forum/index.php/topic,826.0.html).

Anyway, the solution is to use the version of rhyolite-MELTS on the alphaMELTS links page (also linked in the WSL instructions):

https://magmasource.caltech.edu/alphamelts/links.php#linux

The download site at OFM-Research is out of date, particularly the Linux part.

Paula


timothygenda

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Library error when running Melts-rhyolite in Windows x64
« Reply #2 on: August 07, 2020, 03:29:31 pm »
Awesome, thank you!  It's running now :)

Tim